Stems & Assemblies 7/8" to 1-7/16"

 7/8” to 1-7/16”


Stems & Assemblies 1-7/8" to 1-9/16"

 1-7/8” to 1-9/16”


Stems & Assemblies 1-15/32" to 1-5/8"

 1-15/32” to 1-5/8”


Stems & Assemblies 1-5/8" to 1-11/16"

 1-5/8” to 1-11/16”


Stems & Assemblies 1-11/16" to 1-3/4"

 1-11/16” to 1-3/4”


Stems & Assemblies 1-15/16" to 2"

 1-15/16” to 2”


Stems & Assemblies 2" to 2-1/8"

 2” to 2-1/8”


Stems & Assimblies 2-1/8" to 2-5/16"

 2-1/8” to 2-5/16”


Stems & Assemblies 2-1/4" to 2-5/16"

 2-1/4” to 2-5/16”


Stems & Assemlies 2-3/8" to 2-7/16"

 2-3/8” to 2-7/16”


Stems & Assemblies 2-7/8" to 1-15/32"

 2-7/8” to 1-15/32”


Stems & Assemblies 2-9/16" to 2-13/16"

 2-9/16” to 2-13/16”


Stems & Assemblies 2-3/4" to 2-7/8"

 2-3/4” to 2-7/8”


Stems & Assemblies 2-7/8" to 3-1/16"

 2-7/8” to 3-1/16”


Stems & Assemblies 3-1/16" to 3-5/16"

 3-1/16” to 3-5/16”


Stems & Assemblies 3-3/8" to 3-1/2"

 3-3/8” to 3-1/2”


Stems & Assemblies 3-5/16" to 3-9/16"

 3-5/16” to 3-9/16”


Stems & Assemblies 3-25/32" to 4-1/32"

 3-25/32” to 4-1/32”


Stems & Assemblies 4' to 4-1/16"

 4' to 4-1/16”


Stems & Assemblies 4-1/4" to 4-5/16"

 4-1/4” to 4-5/16”


Stems & Assemblies 4-3/16" to 4-7/16"

 4-3/16” to 4-7/16”


Stems & Assemblies 4-7/16" to 4-9/16"

 4-7/16” to 4-9/16”


Stems & Assemblies 4-9/16" to 4-11/16"

 4-9/16” to 4-11/16”


Stems & Assemblies 4-9/16" to 4-3/4"

 4-9/16” to 4-3/4”


Stems & Assemblies 4-31/32" to 5-3/8"

 4-31/32” to 5-3/8”


Stems & Assemblies 5-3/16 to 5-1/2"

 5-3/16 to 5-1/2”


Stems & Assemblies 5-1/2" to 5-17/2"

 5-1/2” to 5-17/2”


Stems & Assemblies 5-17/32" to 5-23/32"

 5-17/32” to 5-23/32”


Stems & Assemblies 5-3/4" to 6-1/4"

 5-3/4” to 6-1/4”


Faucet Seats 7/16 to 9/16" Canadian

 7/16 to 9/16” Canadian


Faucet Seats Less than 7/16" and ½"

 Less than 7/16” and ½”


Faucet Seats 33/64" and 17/32" and 35/64"

 33/64” and 17/32” and 35/64”


Faucet Seats ½" continued

 ½” continued


Faucet Seats 9/16" and 39/64"

 9/16” and 39/64” and Seat Gauge


Faucet Seats 5/8"

 5/8" and Help Tips


Faucet Seats 41/64" to 11/16" Threadless

 41/64" to 11/16" and 23/32" to 15/16" and Threadless


C+C Pluming

 Before and After Pictures
Before and After Pictures

Click Here To Visit My Favorite Site


 Sexaur Hand Book
This is just a referance to help you find the right part.
Please check with C+C Pluming for the proper code and part number.
The print outs are accual size for comparing.


Stems & Assemblies

 Stems and Assemblies
Just click the underlined size on the right side to open the page.
If you print out a document it will be the actual size.
This will help you choose the correct part.